欢迎使用AutoPlay3.0

欢迎使用AutoPlay

  • AutoPlay是一款免费的定时播放软件。通过简单操作，您可以设置以日或者星期为单位的播出任务，并在规定的时间执行它们
  • 本帮助文件将帮助您更好地使用AutoPlay的功能
  • 要获得帮助，请从目录中选择相关主题
  • 如果您是第一次使用本软件，建议您现在开始阅读

如果您在本帮助文件中没有找到与您的问题对应的解答，您可以访问WTZ Software的网站寻求帮助


开始使用AutoPlay

开始使用AutoPlay

  • 需要的准备工作：
    • 系统需求及兼容性：要使用本程序，您的系统应已正确安装Microsoft .NET Framework 2.0框架，以及Windows Media Player 9或更高版本；
    • 检查程序部件：若要正常运行本程序，您需要确保程序部件完整且未经过不恰当的修改。您所获得的文件至少应包括一个可执行文件（通常以.exe为文件名后缀），和一个动态链接库文件（通常以.dll为文件名后缀）；
    • ※如果必要，您会收到“是否安装这个程序”的询问。建议您选择“允许”。
  • 配置AutoPlay
    • 启动AutoPlay，程序界面如下图所示：
      主界面
    • 点击“设置”按钮，或从“开始”菜单中选择详细设置，进入配置页面，如下图所示：
      配置页面
    • 选择“项目类型设置”选项卡，添加要播出的任务类型（详见设置项目类型）；
      配置页面
    • 选择“时间表编辑”选项卡，添加要播出的任务（详见设置时间表）；
      时间表编辑
    • 点击“确认更改”按钮，保存设置。在弹出的确认对话框中，选择“是”；
    • 现在，您应能使用AutoPlay播放您所设置的项目了。
  • 更多功能：AutoPlay提供了其他功能以丰富个性化使用。请从帮助主题中选择对应项目并查看。


AutoPlay主界面

  • 启动AutoPlay后，您将看到如下主界面：
    主界面
  • 主菜单项：
    • 开始：
      • 播放指定文件：手动从文件列表中选择音频文件并直接播放(正在进行的任务将会被中断)；
      • 详细设置：进入设置页；
      • 退出程序：完全退出AutoPlay；
    • 时间表：
      • 加载时间表：打开指定的时间表文件并将其临时用于当天任务安排或者永久成为该星期的安排；
      • 另存为时间表：将当日所使用的时间表保存到其他文件；
      • 校验时间表：检查当日时间表有无错误；(详见编辑时间表)
    • 任务：
      • 任务复位：某些情况下系统可能出现内部错误，如果您不希望重新启动AutoPlay，请使用复位功能即可；
      • 切换手动/自动播放：当您需要临时停止自动播放时，请选择该项。状态栏将会显示切换后的状态(手动或自动模式)
      • 生成任务快照：某些情况下，您可能需要保存当前任务列表中的内容，以便记录或调试AutoPlay的运行情况。选择该项将任务列表以文本形式保存到指定文件；
    • 窗口：
      • 最小化到托盘：手动将窗口最小化并在托盘显示AutoPlay的图标。如果您设置了自动最小化，AutoPlay也会在指定时间后这么做；
      • 永远保持在最前：将主界面窗口置于所有窗口顶端；
    • 帮助：
      • 关于AutoPlay：显示AutoPlay的技术支持信息；
      • AutoPlay帮助：显示帮助文件。
  • 任务列表操作：(在任务列表区点击右键，弹出菜单项)
    • 播放选中项：系统将忽略任务时间，直接播放您选中的任务项。如果是提前播放，则播放后该项不会被删除，亦即系统会在预定时间再次播放该项；如果是已经播放过的项目，则系统不能保证该项目仍然在缓存中，如果系统已经将其从缓存中移除，则播放失败；
    • 删除选中项：将选中项从任务安排中移除。除非您使用“任务复位”功能，或修改配置后选择“立即应用新设置”，否则AutoPlay不会将该项播出；
    • 修改播放时间：临时调整选定项的播放时间。参见播放时间设置；
    • 重新加载列表：清空历史播放记录并从当前时间加载任务列表。这将使得您无法播放已经播过的项目。
  • 快捷按钮：
    • 播放/暂停：如果AutoPlay正在播放某个任务或您正在手动播出指定文件，点击该按钮使得播放暂停或继续。点击按钮右侧的下拉箭头，在弹出的菜单中可以选择“播放指定文件”或“播放选中项”；
    • 停止：停止当前任何正在播放的文件；
    • 手动/自动：在手动播放和自动播放模式之间切换；
    • 设置：进入设置页；
    • 编辑时间表：进入设置页并切换到“时间表编辑”选项卡；
    • 更改音量：临时调整播放的默认音量。注意：该调整将不会被保存，除非您进入配置页调整默认音量。


常规设置

  • 点击“设置”按钮，进入设置页，选择“常规”选项卡：
    时间表编辑
  • 界面设置：
    • 最小化模式：您可以设置软件在一段时间后隐藏主窗口并最小化到系统托盘，这样可以降低系统资源消耗，同时也节省了能源；
      最小化提示
  • 时间表选项：
    • 单个/一周时间表模式：如果您希望一周七天都使用同样的时间表，请选择“单个时间表”，这样系统会将当日的时间表应用到所有星期；如果您希望每天使用不同的时间表，请选择“一周时间表”，并在设置对应时间表的关联星期(参见时间表编辑)；
  • 文件选项：
    • 默认播放文件地址：默认情况下，系统在加载播放文件时，会按您在项目类型设置中所指定的文件名将按照自动匹配。如果您设置的是绝对路径，则无论默认播放地址是否存在都仅按您的设置来查找文件；如果您使用的是相对路径，则系统将会在该文件之前附加默认播放文件地址后再尝试查找文件；
  • 播放选项：
    • 默认音量：有效数值为0-100，0为最小，100为最大。当时间表中某项未指定播放音量时即按该音量播放；
    • 平衡：有效数值为-100-+100，-100为完全偏左，+100为完全偏右。某项音频设备的左右声道输出可能存在差异，您可以通过调节此项来改善播出效果；
  • 任务调度设置：
    • 任务缓存区大小：设置内存中应该缓存(即提前保存)多少任务。数值越大越有利于减少硬盘读取，但是将降低程序运行速度。若无必要，请不要更改；
    • 任务过期后仍然播放：某些情况下，当您调整了时间表或项目类型配置后，当前时间可能已经晚于一些播出项目。勾选此项使得系统即使晚点也将过期任务逐个播出。注意：过期的循环任务不能被播出；
    • 循环播放可以被下一项中断：当您设置了某项循环任务的结束时间晚于下一项任务时，勾选此项使得系统立即中断循环而播出下一项目。否则，将继续播出循环项目直到结束时间；
    • 仅显示当天任务：如果您不希望系统将当天以外的播放任务也列出在主界面上，请勾选此项。


设置时间表

  • 点击“设置”按钮，进入设置页,选择“时间表编辑”选项卡：
    时间表编辑
  • 为“时间表名称”设置一个好记的名字，这样使得您下次使用该表时能够判断它的用途。注意，时间表名称和时间表的文件名可能不同；
  • 点击表格中最底部的空行来添加新项目。每个项目应该包括项目名称(必须且唯一)、类型(根据您在项目类型设置选项卡中设置)、基础时间(亦即该项的播放时间)、音量(非必须，若留空则为默认音量)、是否循环播放和备注；
  • 如果您要删除某一项目，将该项的项目名称删除即可。系统将在更新时自动去除该项；
  • 应用当前表到星期：如果您要指定在特定的时间来播放该表中的项目，请勾选相应的星期。如：周一至周五按照当前安排来播放，请选中“周一”、“周二”、“周三”、“周四”、“周五”。注意：需要将任务模式设为“一周时间表”模式来启用该功能(参见常规设置)；
  • 点击“保存”将更改保存到当前时间表文件。如果您没有加载其他时间表，则系统默认保存到当天使用的时间表中；
  • 点击“加载”打开其他指定的时间表文件并修改。注意：您应当确定该文件是AutoPlay3.0所支持的类型，如果强行打开不正确的文件可能导致系统错误，且可能造成文件损坏！
  • 点击“另存为”将更改保存到其他指定的文件。注意：另存为成功后，系统将展示您所保存的文件而非保存前的文件(如果您没有覆盖源文件的话)。所以，如果您仍然要查看保存前的时间表，请重新加载原文件；
  • 点击“检查”，可以使系统自我分析时间表中的问题，并自动修复。

如果您在本帮助文件中没有找到与您的问题对应的解答，您可以访问WTZ Software的网站寻求帮助。


设置项目类型

  • 概念：AutoPlay使用“项目”的概念来管理每一个要播出的任务；
    • 所有播放任务被划分成相对独立的单位，即“项目”；每一个项目都归属于一项目类型
    • 每一项目类型都有自己的名称，不同项目类型名称不同
    • 每一项目类型有固定的播放时间和播放音量，可以独立存在于时间表中；
    • 每个项目类型也是若干个“子项”的集合，这些子项会项目类型的时间为基准时间，在此前后播放指定的媒体文件；
    • 请参见设置播放时间。
  • 管理项目类型：
    • 进入配置页，选择“项目类型设置”选项卡
      项目类型设置
    • 要实现自动播放功能，至少需要添加一种项目类型。点击“添加”按钮，弹出编辑窗口：
      编辑项目类型
    • 点击“添加”按钮，或选中要编辑的项目类型，弹出编辑窗口。请根据具体需要进行设置：
      编辑子项目
      ※注意：子项名称不能重复，相对时间也不应重复，否则会导致播出安排不正常；
    • 要删除某一项目类型，请先选中它，再点击“删除”按钮；
    • 要修改某一项目类型，请双击它；或先选中它，再单击“修改”按钮；
    • 要一次性删除所有项目类型，请单击“清空”按钮；
    • 关于配置名称：建议您给当前配置起一个好记的名称，这样可以方便管理。在列表上面的文本框中输入即可；
    • 完成编辑后，点击“确定”来保存您的更改。
  • 配置的备份和恢复：（请参见系统配置文件）
    • 恢复配置：如果您之前将配置备份到别处，现在可以单击“加载其他配置”并导入；
    • 备份配置：单击“另存为配置”，将当前配置备份到处到指定位置


设置权限

  • 点击“设置”按钮，进入设置页,选择“时间表编辑”选项卡：
    时间表编辑
  • AutoPlay3.0的权限分为普通用户、维护者和管理员三个角色。普通用户无需登录，也没有任何特殊权限。维护者能够管理普通用户的访问权限，而管理员除了能管理普通用户，还能管理维护者的访问权限；
  • 首次使用AutoPlay时，维护者和管理员的密码均为空，此时直接点击“登录”即可进入对应角色。如果您需要在公共场合使用该软件，建议您立即设置管理员及维护者密码。要修改密码，请登录后点击“修改密码”并输入旧密码。要清除密码，请登录后点击“修改密码”并将新密码留空即可；
  • 例如：管理员权限如下，在您要赋予的权限前勾选即可：
    时间表编辑
  • 修改后请单击“注销”来退出角色，否则可能导致其他人利用您的权限进行不当操作！
  • 忘记密码：如果您是维护者并忘记密码，请联系管理员。如果您是管理员，请联系WTZ Software技术组，或直接访问AutoPlay相关产品页面。


设置播放时间

  • AutoPlay在安排播出任务时，通过计算基础时间和相对偏移来确定具体的播放时间。
    • 基础时间：指某项任务中所有子项所集中的时间。比如A项目包括a,b,c三个子项，播放时间分别为每天的1:10,1:12和1:15,这时您应当将A的基础时间设为1:10(或1:12)；
    • 相对偏移：指某个子项的播放时间相对于其所属的项目的基础时间的差，以秒为单位。仍以上为例，如果A的基础时间设为1:12，则a,b,c相对于A的基础时间应分别设为-120,0和300；
  • AutoPlay允许您对每个项目的子项规定不同的相对偏移，这样当您需要修改几个子项目的播出时间时，就不必考虑绝对时间；当您需要修改几个项目的播出时间时，亦无须考虑其中子项目的绝对播出时间；
  • 请注意：虽然您不需要对每个子项目设置绝对播出时间，但是您在设置时应当考虑到可能的任务重叠情况。AutoPlay允许数个任务的播出时间重叠，但将使用抢占式调度和“后来优先”原则。例如：A项目包括a这一个子项(文件长为60秒)，于1:00播放，而B项目包括b,c两个子项(文件长为120秒和60秒)，分别于1:00和1:01播放，且B项目在时间表中的位置位于A项目之后，那么当1:00时AutoPlay只会播放子项b(a不会被播放)，当1:01时b会被立即中断而播放c。
  • 不恰当的任务设置可能导致AutoPlay调度错误，甚至过度消耗系统资源并导致系统崩溃。如果您在使用中遇到这样的问题，请将其作为BUG反映给WTZ Software。


关于系统配置文件

  • AutoPlay将所有静态配置（即除时间表之外的所有配置）保存在系统文件夹中。
    这些配置由AutoPlay自动生成，并根据您的设置而更改。但是，您不应手动修改它们。
  • 如果有必要，您可以通过备份的方式将配置导出，然后联系WTZ Software的开发人员，由他们协助您解决配置文件中可能的问题。
  • 警告：不恰当的修改可能会导致配置文件损坏，且无法恢复！因用户自行修改配置文件导致的一切后果由用户自行承担。